IE Explorer 6 & 7 no longer compatible

Attention FEPS users:

It is strongly recommended that all FEPS users using Internet Explorer (IE) browser upgrade to the latest version of IE (version 11) if they have not yet done so.  Beginning January 29, 2019, FEPS will require that Transport Layer Security (TLS) 1.1 and 1.2 be enabled in the browser.  IE 11 has TLS 1.1 and 1.2 enabled by default which is why it is strongly recommended users upgrade to version 11.  IE versions 6 and 7 do not support TLS 1.1 and 1.2 which is why they cannot be used.

IE versions 8, 9, and 10 disable TLS 1.1 and 1.2 by default.  Therefore, if you do not upgrade to version 11, you must modify your IE settings to enable TLS 1.1 and 1.2 which may require the assistance of your network team.

If you do not use IE, upgrade to the latest version of the browser you use to ensure compatibility.  We recommend using at least Chrome v33 or higher, Firefox v27 or higher, and Safari v7 or higher.

This change is due to the need for FEPS to disable the outdated Transport Layer Security (TLS) 1.0 and for compatibility with SSO.  TLS is a cryptographic protocol used to protect the confidentiality and integrity of data over the internet.


Need FEPS Help?

Call the FEPS Helpdesk at 801.352.3338 or email at feps.support@conduent.com

 



PRIVACY AND SECURITY NOTICE

This is a Conduent computer system that is "FOR OFFICIAL CONDUENT USE ONLY" by specifically authorized personnel and includes Conduent confidential, proprietary, and privileged information. This system may be subject to monitoring. No expectation of privacy is to be assumed. Unauthorized attempts to upload, download, or change information on this system are strictly prohibited and may be punishable under applicable law. Individuals found performing unauthorized activities are subject to disciplinary action including termination and criminal and civil prosecution. Anyone using this system must agree to abide by Conduent policies.